Forum EduPython

Echanges autour d'EduPython.

Vous n'êtes pas identifié(e).

#1 2020-04-21 17:28:59

magicvinni
Administrateur
Inscription : 2017-12-22
Messages : 283

Les modules à installer

J'ai repris les différentes demandes déjà faites :

  • FOLIUM

  • PIL ou PILLOW

  • PANDAS

  • PYROUTELIB3 (routage)

  • pyopengl ( 3D temps réel)

  • opencv et pyqrcode

  • pandas

  • nanpy

Hors ligne

#2 2020-04-21 21:33:37

magicvinni
Administrateur
Inscription : 2017-12-22
Messages : 283

Re : Les modules à installer

Je viens de mettre tous les modules et regardé au fur et à mesure la taille du dossier (en Go). Voici ce que ça donne :

1.22    numpy + matplotlib
1.31    lycee + scipy
1.33    pillow                    conda install pillow
?     pandas                    conda install pandas
1.38    pygame                    pip install pygame
1.42    mysql-connector-python pyserial        conda install mysql-connector-python pyserial
1.42    nanpy                    pip install nanpy
1.42    folium                    pip install folium
1.42    pyroutelib3                pip install pyroutelib3
1.42    pyknon                    pip install pyknon
1.45    scikit-learn                conda install scikit-learn
1.46    PyOpenGL PyOpenGL_accelerate        pip install PyOpenGL PyOpenGL_accelerate
1.46    PyQRCode                pip install PyQRCode
1.52    sympy                    conda install sympy
1.52    giacpy                    pip install giacpy
1.66    jupyterlab                pip install jupyterlab
1.75    opencv                     pip install opencv-python

C'est un peu gros... mais en même temps, les "gros" modules sont utiles. Je pense que l'on peut retirer sympy (calcul formel) et opvencv, mais pour le reste, je ne vois pas trop.

A suivre, n'hésitez pas à tester cette nouvelle version.

VM

Hors ligne

#3 2020-04-24 16:01:48

nico
Membre
Inscription : 2020-01-09
Messages : 22

Re : Les modules à installer

j'ai essayé pyinstaller pour créer des exe et ça marche plutôt bien
mais c'est une utilisation particulière.

Hors ligne

#4 2020-04-30 13:18:33

piphi
Membre
Inscription : 2019-03-31
Messages : 3

Re : Les modules à installer

J'ajouterais bien la demande du module networkx qui semble utile en SNT et qui le sera surement pour la NSI en Terminale.

Il me semble qu'il n'est pas installé par défaut. Il faudrait donc peut-etre l'ajouter dans la liste des modules à installer.

Dernière modification par piphi (2020-05-01 19:32:49)

Hors ligne

#5 2020-05-03 17:18:26

nico
Membre
Inscription : 2020-01-09
Messages : 22

Re : Les modules à installer

lulutima, on en parle dan sun pot a part ou en mp.
Je prepare un mini tuto (ça tiens en 3 lignes)

Hors ligne

#6 2020-05-03 17:21:18

magicvinni
Administrateur
Inscription : 2017-12-22
Messages : 283

Re : Les modules à installer

Nico, si tu veux faire une page su le wiki, je suis preneur smile !

Merci d'avance

Vincent.

P.S : Désolé, mais avec la reprise des cours et les concours qui approchent, les étudiants sont assez demandeurs, donc j'ai un peu mis en stand by la mise en place de la version 3 pour quelques semaines.

Hors ligne

#7 2020-09-09 20:28:19

rcharp
Membre
Inscription : 2020-09-09
Messages : 1

Re : Les modules à installer

Bonsoir,
j'arrive (juste) après la bataille, donc ce sera pour une version ultérieure,
mais il y a le module metakernel qui serait intéressant à intégrer,
car il permet d'insérer un cadre PythonTutor (voir Pythontutor.com pour ceux qui ne connaîtraient pas) dans un notebook,
à condition de mettre ces deux lignes

from metakernel import register_ipython_magics
register_ipython_magics()

puis de préfixer la cellule par

%%tutor

Un autre module sympa est mpmath (multiprecision math), qui permet de travailler avec un nombre arbitraire de décimales.

from mpmath import mp
mp.dps=100
u=mpmath.mpf(1)
for k in range(10):
    u=(u+2/u)/2
    print(u)

Dernière modification par rcharp (2020-11-17 19:23:12)

Hors ligne

#8 2021-04-22 08:14:01

X DEFER
Membre
Inscription : 2021-04-22
Messages : 2

Re : Les modules à installer

Bonjour,
Il semble que le module networkx ne soit pas installé par défaut dans cette nouvelle version. Toutefois, il me serait bien utile afin de tracer des graphes pour une activité en SNT. Est-il possible d'installer des modules complémentaires à postériori ?
Merci

Hors ligne

#9 2021-04-22 08:40:12

X DEFER
Membre
Inscription : 2021-04-22
Messages : 2

Re : Les modules à installer

Re...
En consultant les différentes questions sur le forum, j'ai trouvé comment installer un module supplémentaire, notamment en consultant la page 94 de la documentation.
Bonne journée.

Hors ligne

Pied de page des forums