Forum EduPython

Echanges autour d'EduPython.

Vous n'êtes pas identifié(e).

#1 2021-03-04 13:52:03

matty
Membre
Inscription : 2021-03-04
Messages : 1

problème module

Bonjour à tous,
  j'ai un problème avec edupython, lorsque j'essaie d'utiliser matplotlib j'ai le message suivant qui apparait au moment de l'exécution

>>> import matplotlib.pyplot as plt
Traceback (most recent call last):
  File "<interactive input>", line 1, in <module>
  File "C:\EduPython\App\lib\site-packages\matplotlib\__init__.py", line 205, in <module>
    _check_versions()
  File "C:\EduPython\App\lib\site-packages\matplotlib\__init__.py", line 190, in _check_versions
    from . import ft2font
ImportError: DLL load failed: Le module spécifié est introuvable.
>>>
    Etrangement, pendant un moment, je n'avais pas de problème mais depuis quelque jour cela ne marche plus. J'avais une version 2.7 du coup de l'ai désinstallé pour installer une version plus récente, mais j'ai le même problème

Si vous aviez des pistes de recherche à me donner
Merci d'avance

Dernière modification par matty (2021-03-04 13:52:30)

Hors ligne

#2 2021-03-05 15:27:37

magicvinni
Administrateur
Inscription : 2017-12-22
Messages : 283

Re : problème module

Bonjour,

    Oui, c'est étrange

Piste 1 : Vous avez d'autres versions de Python installées : http://edupython.tuxfamily.org/forum/vi … php?id=204 (mais là ça ne semble pas le cas)

Piste 2 : Essayez d'installer EduPython dans C:\EduPython (répertoire par défaut)

Piste 3 : L'antivirus qui aurait mis en quarantaine certains fichiers....

Tenez-moi au courant.
VM

Hors ligne

Pied de page des forums