Forum EduPython

Echanges autour d'EduPython.

Vous n'êtes pas identifié(e).

#1 2018-01-01 15:05:09

cchiavassa
Membre
Inscription : 2018-01-01
Messages : 1

écriture algorithme - Recherche d'un maximum

je ne parviens pas à écrire le programme de recherche de maximum en langage python. La fonction est -0.15x^2+x+1.5 définie sur l'intervalle [0;8].
Merci pour votre aide....

Hors ligne

#2 2018-01-02 18:03:36

magicvinni
Administrateur
Inscription : 2017-12-22
Messages : 67

Re : écriture algorithme - Recherche d'un maximum

Bonsoir,

     ça semble compliqué de trouver le maximum sur l'intervalle [0;8] puisqu'il existe une infinité de nombres réels dans cet intervalle [0;8], on peut par contre avoir une idée du résultat en prenant un "petit" pas. Voici un exemple d'algorithme :

-> On définit la fonction f par exemple

-> Programme principal :

maxi <- f(0)
x <- 0
pas <- 0.1
TANT QUE x <= 8 :
     SI f(x) > maxi ALORS #Si on trouve mieux que le maximum que l'on avait
         maxi <- f(x)           # On met à jour la valeur du maximum
    FINSI
    x <- x + pas
FIN TANT QUE
AFFICHER maxi

On peut alors jouer sur le pas pour étudier l'effet.

VM

Hors ligne

Pied de page des forums